[root]/Packages/Uintah/StandAlone
Benchmarks
(0 files, 0 lines)
tools
(0 files, 0 lines)
compare_mms
(0 files, 0 lines)
dumpfields
(0 files, 0 lines)
extractors
(0 files, 0 lines)
graphview
(0 files, 0 lines)
makedot
(0 files, 0 lines)
mpi_test
(0 files, 0 lines)
pfs
(0 files, 0 lines)
puda
(0 files, 0 lines)
radiusMaker
(0 files, 0 lines)
tracker
(0 files, 0 lines)
uda2nrrd
(0 files, 0 lines)
uda2vis
(0 files, 0 lines)
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 39 (100.0%) | 401 (100.0%) | 10.2 |
jas | 19 (48.7%) | 240 (59.9%) | 12.6 |
dav | 12 (30.8%) | 129 (32.2%) | 10.7 |
luitjens | 8 (20.5%) | 32 (8.0%) | 4.0 |
Remove Packages/
0 lines of code changed in 8 files:
M StandAlone/sus.cc
Don't show a stack trace if a ProblemSetupException is caught. (In
these cases, the stack trace does not provide any helpful
information.)
M CCA/Components/ProblemSpecification/ProblemSpecReader.cc
When a tag is missing, there is not xml node from which to extract
a line number, so don't try to do it.
0 lines of code changed in 2 files:
Removed setprecision call that was accidently commited.
0 lines of code changed in 1 file:
Use handles to track .ups parsing and validation information. This
provides for giving the memory back when the validation is done.
Changed the system so that once validation is done, all memory is
given back... if another .ups file is read, then validation data is
read in again, validation is done, and the memory is given back.
Usually validation is only done 1 time per simulation, and it only
takes a second to validate, so this shouldn't be a problem.
M CCA/Components/ProblemSpecification/ProblemSpecReader.h
* Cosmetics to make code slightly easier to read.
M CCA/Components/ProblemSpecification/ProblemSpecReader.cc
* Added 'handle' code and ability to return memory when validation is done.
* Expanded the error message Jeremy was getting to make fixing ups_spec.xml easier.
* free the xml validation (ups_spec.xml) doc when validation is done (returning memory to the system).
* Still need to clean up this code a little, but want to get it in for the RT.
* Throw a couple of new exceptions in cases that should never happen (instead of just returning).
M StandAlone/inputs/ups_spec.xml
* Added some cosmetic whitespace (it is your friend).
* Place 'attribute' on its own line to make viewing file easier.
M StandAlone/sus.cc
Give back 'ups' memory when no longer in use.
5 lines of code changed in 1 file:
Inform the user which implicit solver is being used (note this does not mean it is actually used, but if implicit code is being used this is the solver that would be used).
4 lines of code changed in 1 file:
Updates to Region::difference.
1) Fixed a bug where the function did not properly handle subtracting an empty set
2) No longer includes zero sized regions in the results
3) Changed deque to a vector as we didn't use any of the deque features and vetors are more widely understood.
1 lines of code changed in 2 files:
Turned on .ups validation... You need to update your .ups files and
the ups_spec.xml file now! If your problem specification is not
valid, sus will die (with an error message) immediately. You can
validate an .ups files with "sus -validate filename.ups".
M Core/Containers/StringUtil.h
M Core/Containers/StringUtil.cc
Utility function to print out a vector<string> as a single ',' separated string.
M Packages/Uintah/CCA/Components/MPM/PetscSolver.cc
* Comment.
M Packages/Uintah/Core/GeometryPiece/GeometryPieceFactory.cc
M Packages/Uintah/CCA/Components/SimulationController/SimulationController.cc
* Removed setting of writeMessages.
M Packages/Uintah/CCA/Components/Parent/ComponentFactory.h
M Packages/Uintah/CCA/Components/Parent/ComponentFactory.cc
* Don't pass in the name of (the type of) a component anymore... It is read from the .ups file now.
M Packages/Uintah/CCA/Components/Parent/Switcher.h
* Cosmetics
M Packages/Uintah/CCA/Components/Parent/Switcher.cc
* It is possible that I broke this... I think it is ok, but I'm going
to get this commit in so that the RT can take a look.
* Cosmetics
* Organize #includes.
* The ProblemSpec no longer comes from a port... Just hold onto it when Switcher is initialized.
M Packages/Uintah/CCA/Components/LoadBalancers/DynamicLoadBalancer.h
* Cosmetics - whitespace is your friend. :)
M Packages/Uintah/CCA/Components/LoadBalancers/DynamicLoadBalancer.cc
* Don't need two steps anymore to read a problem spec.
M Packages/Uintah/CCA/Components/DataArchiver/DataArchiver.cc
* Don't need two steps anymore to read a problem spec.
M Packages/Uintah/CCA/Components/Solvers/SolverFactory.cc
* <Solver>
<type>
replaced with:
<Solver type="">
M Packages/Uintah/CCA/Components/ProblemSpecification/ProblemSpecReader.h
* Major updates to ProblemSpec validation.
** Tracking the actual file that specific tags come from to better report errors to user.
** Don't 'create' a PSReader with a filename, just call readInputFile() with the filename.
Might should make readInputFile a static function, but haven't yet as I'm not sure
if it is used multiple times for the same ProbSpec.
** Prob Spec Reader now contains a list of all (xml) files that were read to create the PS.
* Functions used to pass in the tag (parent), but since they are part of the tag class, don't need
to do this. It is implicitly done (parent == this).
* Moved the Tag/Attribute structs out of the ProblemSpecReader class as they aren't really
a part of it, and are not needed anywhere but in ProblemSpecReader.cc.
* Remove #include sgi stuff.
M Packages/Uintah/CCA/Components/ProblemSpecification/ProblemSpecReader.cc
* Display filename and line number when errors are found.
** All tags are added to the main (top level) xml 'doc'ument. Because of this, the filename
of sub-docs was lost. I am catching this and using the *_private (part of an xml node)
to hold onto this info. I think this is ok as the xml documentation says that it is for
application use.
* Added need_applies_to and children requirements parsing.
* Fixed a couple of edge condition errors that could slip through the parsing.
* Consolidate the file name validation. First look for the file specified directly,
then look for it as a relative offest from its parents location,
then look for it as an absolute offset from where the program was run.
I think this covers all the cases that people use and that it makes sense
to do it this way.
M Packages/Uintah/CCA/Components/Arches/Arches.cc
* Made 'whichMMS' an attribute (instead of a separate <Tag>).
M Packages/Uintah/CCA/Components/Regridder/RegridderFactory.cc
* Changed <type> to be an attribute of <Regridder type="">.
M Packages/Uintah/CCA/Ports/ProblemSpecInterface.h
* Pass filename into readInputFile().
* Cosmetics
M Packages/Uintah/scripts/regression_tester
* Allow 'inputs' to be INPUTS to be local as well as in relative src location.
M Packages/Uintah/Core/DataArchive/DataArchive.cc
* One stop readInputFile().
* Catch edge error condition. (d_filebase == "")
M Packages/Uintah/Core/ProblemSpec/ProblemSpec.h
* Removed doWrite... as it wasn't (really) used anywhere, and I'm not sure what its purpose was.
* Cosmetics - whitespace is your friend
M Packages/Uintah/Core/ProblemSpec/ProblemSpec.cc
* Cosmetics - use '{}' and whitespace.
* removed d_write
M Packages/Uintah/StandAlone/tools/compare_mms/compare_mms.cc
M Packages/Uintah/StandAlone/tools/graphview/GV_TaskGraph.cc
M Packages/Uintah/StandAlone/slb.cc
M Packages/Uintah/StandAlone/restart_merger.cc
* One stop readInputFile()
M Packages/Uintah/StandAlone/tools/pfs/pfs.cc
M Packages/Uintah/StandAlone/tools/pfs/pfs2.cc
* One stop readInputFile()
* Removed writeMessages()... don't think it is used anywhere...
M Packages/Uintah/StandAlone/sus.cc
* Clean up 'usage'.
* No more "-mpm" or "-arches", etc... Specify in .ups file.
* FinalizeManager (finalize MPI) was needed in a number of error cases.
M Packages/Uintah/StandAlone/inputs/ups_spec.xml
Lots of updates... Needs a lot more work from those in the know.
Please fix all the FIXMEs. If a parameter is optional, please specify
why and/or its default. Also, make as many things 'REQUIRED' as
possible. Update the children and need_applies_to flags too.
Please put <tags> in ALPHABETICAL order... this will make it much
easier to find and verify them! Try to organize the large <tags> in
sections (as they apply to need_applies_to), but keep each section
alphabetical.
M Packages/Uintah/StandAlone/inputs/*/*.ups
* Updates to be closer to spec.
46 lines of code changed in 5 files:
Fixes to make restart_merger work again. (Not sure how this will
effect an UDA that used the 'switcher' component... John may need to
take a look. However, for the time being, 'simple' UDAs seem to merge
correctly.)
M restart_merger.cc
- Added some needed and alphabetized #includes.
- Cleaned up the usage() a little to include description of what the
program is used for.
- Added the simulation component to the DataArchiver so that the
correct output spec can be output.
M sub.mk
- Added in required libraries and alphabetized them.
65 lines of code changed in 3 files:
Set compare_uda's default exit mode to exit and not wait.
2 lines of code changed in 1 file:
Add the MIT License to every *.cc, *.h,*.F, and sub.mk file.
240 lines of code changed in 11 files:
Use the variable basis to determine the testing ranger for a variable. This prevents a bug where compare_uda would use a combination of node/cell index ranges which could pull data from the wrong patch.
19 lines of code changed in 1 file:
Fully qualify the namespace to avoid a compile error.
1 lines of code changed in 1 file:
When there are overlapping patches (possible with extracells) compare uda gives priority to the patch that has that cell/node in the interior. This patch updates the tiebreaker to give priority to the patch that has the cell/node index within extra cells instead of extra nodes.
With extra nodes there is a corner case where two patches own the same node. In this case both nodes should have the same value. However, compare uda uses the same patch map for all variables (based on nodes). This causes problems when looking at a cell which is on this corner case. The current code treated the cell as a node and believed they would have the same value. This is incorrect because with cells one patch owns the cell and the other doesn't and thus only the patch that owns the cell is gaurenteed to have the correct value.
5 lines of code changed in 1 file:
Added the ability to specify an "abort" handing/cleanup function for a
thread. If this routine is specified, then it will be called from the
segfault/segbus signal abort handling routine. This allows the main
program to tell its thread how to clean up. It was inspired by the
need for Uintah to tell MPI to abort when one process in a large MPI
run dies.
M Core/Thread/Thread.h
* Added (g/s)etCleanupFunction() which allows a program to give its
thread a clean up routine to be called if the program segfaults
(segbus's).
* Indentation. Cleanup of '{'s.
M Core/Thread/Thread.cc
* Added (g/s)etCleanupFunction() code.
* Cleanup/Indentation.
M Core/Thread/Thread_pthreads.cc
* Only real coding update is this...
> Thread::ptr2cleanupfunc funcPtr = Thread::self()->getCleanupFunction();
> if( funcPtr != NULL ) {
> (*funcPtr)();
> }
...which calls the cleanup function if it was specified.
* Indentation/Cleanup.
M Packages/Uintah/StandAlone/sus.cc
* Added abortCleanupFunc that will be called in the Uintah thread segfaults (segbus, etc).
* Cleanup #includes a little.
13 lines of code changed in 1 file: