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Chapter 1

Overview

This tutorial describes step by step instructions to segment Ascending and Descending Aorta in car-
diac MRI and describes the segmentation of skull, gray and white matter in a head dataset.

1.1 Software requirements

1.1.1 Seg3D 1.11

Seg3D is distributed as a binary download for Linux, Windows, and OS X. Please visit the
SCI software portal (http://software.sci.utah.edu ) to download the latest Seg3D binary.
Any version of 1.11 or higher will do.

1.1.2 Required Datasets

This tutorial uses two datasets. The first one is a set of two 3D scans, one is an anatomical
MRI of the atria and the second one is a delayed enhanced MR image of the same region.
Both images have been registered. The second data is a brain data set that contains a
preoperative MR image of the brain and a post surgery CT image of a pediatric patient.

The datasets are available in the SCIRunData zip files. The datasets for this tutorial
are inside the Seg3D directory.
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Chapter 2

Basic Orientation

Scope: Navigating in Seg3D

Figure 2.1. Loading a volume
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Figure 2.2. The main Seg3D window

2.1 Loading A Dataset

In order to get a good feel for the Seg3D program, one needs to load a dataset. Please open
up the file menu and select the Open Volume menu item as indicated in figure 2.1. This
opens up a file browser. Browse to the Heart DataSet directory and select this one to load
the DEMRI.nrrd file.

Note: we converted the datasets for this demo into the NRRD dataset format as it
does not contain any patient information. Seg3D reads as well dicom files and any image
file format supported by the Insight ToolKit, as well as Matlab files. The browser decides
which fileformat to use based on the extension of the file.

Once the file has loaded one can see the data being displayed in the 3 slice views and the
3D viewer. The layout of the Seg3D program is highlighted in figure 2.2. On the top left
one has a tool menu that will show the options of the currently loaded tool and is currently
empty. On the right one can see the layer menu. Each layer in Seg3D is a separate volume
and the order in the Layer Editor depicts the order in which datasets are being shown. In
the center one has the three orthogonal views and one 3D viewer and to the lower left one
can browse the position of the active dataset and sample the value.

2.2 Navigation

Brightness Move the mouse up and down while pressing left mouse button.

Contrast Move the mouse left and right while pressing left mouse button.
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Pan Volume Press shift and move volume while clicking left mouse button.

Zoom Move the mouse up and down while pressing the right mouse button.

Rotate Move the mouse while pressing the middle mouse button in the 3D viewer.

Move slice orthogonal slices Move the mouse while pressing the middle mouse button
in the 2D view windows. This will change the location of the two colored lines, which
represent the location of the two other slice windows.

Move slice depth Use the mouse wheel to move to the next slice. Or use the < or > keys
to navigate through a slice.

Painting In painting mode the mouse wheel is the size of the brush, hence to move through
slices use the < or > key.

Plane visibility Press space to switch off viewing the image and space again to switch it
on.

Navigate through the data and rotate the 3D image.

2.3 Changing Views

To alter the views that are displayed in the window. Press on the Red, Green, or Blue tab
at the top of each Viewer to show a different viewer. By clicking on the labels one loops
through the four main modes of each window.

In the Views menu one can further specify the layout of the views. One can choose
from:

Two by Two The default.

One and Three Make one window big.

Single Just showing one window.

2.4 Loading a second dataset

Open the Load Volume menu once more and now load the Angio.nrrd dataset. After
loading this dataset now two datasets are present in the menu on the right. Press on the eye
to show which layer is visible. As volume layers are full data layers they completely clutter
the underlying image. Switch on the visibility of both layers and toggle the visibility of the
top most layer. The top most is the one found on top of the menu. The blue highlight set
the selected layer. Select the top layer and press space and press space again (on Windows,
put the cursor in the Viewer Window). This option can be used to quickly navigate between
different layers.
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Chapter 3

Simple Operator Based Segmentation
Strategies

Scope: Paint Tool - Polyline Tool - Logical Operators - Creating Isosurfaces - Masking Data - Saving
Data - Morphological Filters

3.1 DEMRI Dataset

In this section we will use the paint and polyline tools to segment a simple structure, the
aorta, from the DEMRI dataset. Delayed enhancement MRI (DEMRI) makes use of the
contrast enhancement that gadolinium (Gd) provides in MR imaging. In this scan Gd was
injected via IV into the patient’s venous system. As the Gd washes through the system
it enters and exits tissues at variable rates. In this case, 15 min. after administration,
the Gd has washed into and out of most tissue. Contrast enhanced tissues that continue to
sequester Gd are assumed to have disrupted, or altered vascular perfusion. This method has
be used to detect cardiac ischemia, infarct, and scarring. This particular DEMRI dataset
was used to evaluate post-operative scarring in the left atrium. To get started, we will be
looking at the ascending and descending aorta.

3.2 Label Masks

Seg3D has two types of layers that can operated on by different tools and filters. These are
volume and label masks. Volumes are image data that has been loaded in, or produced by
one of the filters. The DEMRI and Angio datasets loaded in the first section are volumes,
and appear left aligned on the Layer Menu. If you select the + button below either of these
volumes a new layer with the same name appears indented above the volume. This is a label
mask. The label mask displays the segmented regions of interest as a colored opaque layer.
When using any tool or feature it is important to know whether it operates on a volume,
label mask, or both.
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Figure 3.1. Painting the lumen of the descending aorta.

3.3 Paint Tool

The paint and polyline tools allow the user to directly select regions of interest for segmen-
tation. The paint tool presents as a circle icon of adjustable radius that can select regions of
interest by holding down the left mouse button and moving the icon over the desired object.
The polyline tool is operated by selecting points, with the left mouse button, around the
perimeter of the region of interest. Each point added is connected to the point before it and
to the first point selected making a closed polygon. Both tools display the selected regions
of interest in label masks.

Begin by selecting Paint Brush under Tools on the menu bar. When the circular icon
appears, experiment with the tool by moving it over the three orthogonal image planes. You
will notice that the icon is elliptical over the Coronal and Sagittal planes and is circular over
the Axial plane. Click on the i button under DEMRI on the Layer Menu and information
about the volume will open. Next to Spacing is listed the voxel dimensions (0.62, 0.62,
2.5). With respect to the Axial plane this means the slice thickness is nearly 4X the size
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Figure 3.2. Polyline for masking the superficial surface of the ascending aorta.

of X-Y spacing. When using other features in Seg3D it is important to remember that the
anisotropy of your data is preserved.

Prepare to segment by clicking on the + widget under DEMRI on the Layer Menu to
create a label mask. Begin segmentation of the aorta by navigating the Paint icon over the
Descending Aorta on the axial plane. Adjust the diameter of the tool with the scroll
wheel, or by holding the right mouse button until it just fills the lumen of the aorta. Once
you have positioned and sized the icon click the left mouse button. The circle icon should
then fill with the same color of the selected label mask. Proceed to the next few slices
painting the lumen of each one (Figure 3.1). Next, create a new label mask, and expand
the diameter of the Paint icon so it encircles the outer diameter, or superficial surface of the
aorta. Now paint the superficial surface of the same slices. It is possible to erase painting
on the label mask by holding the right mouse button and moving the icon over the region
to be erased.
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Figure 3.3. Polyline for masking the lumen of the ascending aorta.

3.4 Polyline Tool

The Polyline Tool may be better suited for segmentation of complex shapes. Open the
Polyline Tool under the Tools menu on the menu bar. Without changing the label mask,
begin clicking points around the superficial surface of the Ascending Aorta (Figure 3.2).
If you are not satisfied with the location of a point you can move it by right clicking on it
and dragging it to the desired location. Or, you can simply delete the point by hold alt and
left clicking. It is also possible to add a new point between points by right clicking on the
line between two points. Once you have traced the superficial surface all the way around
click fill on the Tool Menu, or simply press F on the keyboard. The region surrounded by
the polyline should fill with the color of the selected label mask. Navigate to the next slice,
and notice that the polyline does not disappear. If the polyline still matches the region of
interest, simply hit F. To adjust the polyline hold the right mouse button to move the entire
polyline, or move individual points as described before. If you want to start over hit C on
the keyboard to clear the polyline. It is also possible to erase regions of the label mask with
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Figure 3.4. Creating label mask of region of interest with logical operators.

the Polyline tool by creating a polyline around the region to be erased and selecting erase
on the Tool Menu. After creating the superficial surface label masks hide the masks by
clicking on the eye widget, select the lumen label mask, and use the Polyline tool to create
lumen masks on the Ascending Aorta (Figure 3.3).

3.5 Logical Operators

Once you have masked the lumen and superficial surface of both the ascending and descend-
ing aorta we can use logical operators to mask the real region of interest, the aorta wall.
Under Filters on the menu bar, select Combine Labels with Logical Xor. Highlight either of
the label masks and click the Set Mask Label on the left hand Tool Menu. The highlighted
label mask should turn pink. Next select the other label mask and click Start. This will
create a new label mask that only covers the aorta wall (Figure 3.4).
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Figure 3.5. Creating isosurface of label mask.

3.6 Isosurface

To create a three dimensional isosurface of the Xor label mask, select Xor on the Layer
Menu. It may be necessary to clear the set label mask by selecting Clear Label Mask under
the Edit menu. Once Xor is the only layer highlighted, return to the Edit menu and select
Isosurface Current Label and click Start. Now the 3D View in the upper right corner should
display the 3D isosurface (Figure 3.5). Navigate around the volume with the normal zoom
and pan volume short keys. Holding the alt key and clicking on the volume will allow you
to rotate the object. Experiment with the widgets in the bottom right corner to turn on
and off various elements of the display.

3.7 Mask Data

To extract the data covered by the label mask select the Mask Data option under Filters
menu. Choose the label mask you want to use to extract data with and click Set Label
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Figure 3.6. Using label mask to extract data from volume.

Mask in the Tools Menu. Then select the volume you want to extract data from (DEMRI
in this case), and click Start. A new left aligned volume will appear at the top of the Layer
Menu. This should show only the region of interest from the masked volume (Figure 3.6).

3.8 Saving

At this point there are multiple options for saving the work that you have done. Under the
File menu are the options: Save Volume, Save Session, and Export Segmentation. The Save
Volume will the volume selected in the Layer Menu. Save Session will save the work that
you done to this point in a single session file for later restoration. This include both label
masks and volumes. The Export Segmentation option save the label masks that you have
created. If you wish to save your volume in Dicom format replace the file extension .nrrd
with .dcm.
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Chapter 4

Filters and Threshold Tool

Scope: Using Masks - Filtering Data

Figure 4.1. Angiogram
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Figure 4.2. Median and Gaussian filtered Angiogram

4.1 Loading Angiogram

The second cardiac dataset that is part of this example is the angiogram. For this part of
the tutorial load the Angio.nrrd file. Use the Load Volume menu in the File Menu to load
this dataset. An example of this dataset is depicted in figure 4.1.

This dataset was previously registered to the DEMRI.nrrd dataset. As both datasets
have the sampling distance and coordinate system. One can use label mask from the DEMRI
dataset in the Angio dataset and vice versa.

4.2 Filtering data

As we want to use the threshold tool on the Angiogram data to segment out the inner wall
of the both ascending and descending aortas, the data noise in the MR image needs to be
suppressed. In this example we use a Median and Gaussian Filter to filter the data.

Select the Angio volume layer and now open up the Median Filter from the Filters
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Figure 4.3. Thresholding Angiogram while looking at DEMRI

menu. The radius in the Tool Menu indicates the number of the neighboring pixels that is
used to derive the median from. In this case the default setting of one will be sufficient.
Run the filter and compare the results by pressing space to toggle on and off the selected
layer, which in this case should be the top most layer that was just generated.

The second stage of filtering uses the Discrete Gaussian Filter from the Filter Menu.
Again the default settings will do. Select the output from the median filter and run this
filter. After filtering the data will look like the results depicted in figure 4.2.

4.3 Threshold Tool

To select the blood from the segmentation, use the Threshold Tool from the Tools menu.
Once this tool has been opened, use the sliders to adjust the segmented region. In order
to do this, switch off the visibility of both the filtered Angio datasets as well as the orginal
Angio dataset and make the DEMRI visible. Now select the filtered Angio dataset again
and use the the sliders to interactively generate a segmentation of the blood.

Once the segmentation looks good press complete in the Tool Menu to generate the
label layer. (see figure 4.3) The threshold tool however segments both aortas and the left
atrium. To select just one of the of the vessels, select the newly created label layer and then
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Figure 4.4. Painting a label while masking from another label

select Set Mask Label in the Edit Menu.
Now create a new layer by pressing on the + symbol in this layer. This will generate

a new empty layer with the same dimensions. Now open up the Paint Tool in the Edit
Menu and start painting the Ascending Aorta. As a mask has been set the painting will be
restricted to previously segmented blood. (see figure 4.4)

Paint a couple of slices and then extract the isosurface of the is vessel. This in short
shows a different method of getting the inside of the aortas and can be used to substitute
the methods shown earlier.
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Chapter 5

Speedline Tool

Scope: Speedline Tool Segmentation

5.1 Speedline Tool Segmentation

In this example we will use the Speedline Tool (Also known as the Live Wire Tool) to
segment the Left Atrium. We start off with the Median Filtered Angiogram. This data will
be the data on which we will using the speed tool.

Figure 5.1. The speed function displaying the gradient of the dataset
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Figure 5.2. Creating a speedline contour

Open up the Speedline Regular Step tool from the Tools menu. The first thing before
one can use the speedline tool is to compute a gradient image. This gradient image can be
computed by pressing Create Speed Function in the tool menu on the left. This will
create a new data volume with the gradient. The speedline tool will use this image to trace
a line along boundaries of tissues.

Figure 5.1 shows the resulting speed function, which highlights the contours of the
Ascending and Descending Aorta as well as the Left Atrium. As the structures are less
recognizable from the speed function, we switch off the visibility of the speed function layer
by pressing on the eye in the layer menu on the right hand side for this layer.

Now the underlying layer becomes visible. Now we are ready to use the Speedline Tool.
Insert a point in to of the border of the left atrium and a second point at some distance and
a third point even further. Now drag this point along the border and the tool will follow
edge of the volume. Add points at the corners and drag the speedline along the left atrial
wall. An example of this is shown in figure 5.2.

Once the speedline has been completed, it can be filled in by hitting F or selecting Fill
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Figure 5.3. Filling in a speedline contour

from the Tool Menu on the left. Make sure that no Label Mask has been set as the Fill
operation will automatically mask out any part that is not part of the mask.

Now a segmentation is generated in one slice, proceed to the next slice by press < or
>. The speedtool will try to accommodate it’s shape to the new cross section. However
manual corrections can be made by moving points around using the right mouse button and
dragging point around, or by adding additional points by pressing the right mouse button
in the center of a segment. Press F again to fill in the segmentation. (see figure 5.3).

By doing this sequentially for many slices, one can quickly segment a section of a struc-
ture. Once a portion of the structure has been segmented. Use the Isosurface Current
Label tool in the Edit menu to visualize the results in the 3D.

This concludes the cardiac part of this tutorial. The next chapter will highlight some of
the tools using a head dataset.
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Chapter 6

Segmenting a Brain Dataset

Scope: Neighborhood Connected - Thresholding using Points - Multiple Datasets -

6.1 Loading Datasets

This part of the tutorial deals with segmenting a head dataset. The data that will be used
is that of a 15 year old pediatric patient. This patient underwent surgery during which

Figure 6.1. Loading the brain dataset into Seg3D
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Figure 6.2. Selecting seed points for Neighborhood Connected filter

electrodes were implanted into the brain cavity. The image that we will be using are the
MR image that was taken before the surgery and the CT image that was taken after. Note
that one can clearly see in the image where the electrodes were inserted.

The final goal of this research is generate a patient specific model which can be used to
find focus of brain activity during a seizure. For this a full volumetric representation of the
head is needed. In this example we are extracting three tissues, namely the skull, the white
matter and the gray matter. The remaining scalp and CSF can be obtained similarly, but
is outside the scope of this tutorial.

6.2 Neighborhood Connected

Browse the Brain DataSet directory and load the following two files: CTbrain50.nrrd and
MRI-brain50.nrrd. The first one is the post operative CT image and the second one is the
pre-surgery MR image. After loading the datasets the Seg3D window should look like the
one in figure 6.1.

Note that the data is not perfectly registered and that a part of the skull has been lifted
to actually insert the electrode arrays.

To segment out the Skull we will be using the CT image. Select the CT image in the
Layer Menu. Now from the Filters menu select the Neighborhood Connected filter. This
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Figure 6.3. Isosurfacing of Skull Segmentation

filter needs seed points and finds every connected tissue of the same gray scale range. Hence
placing seed points needs to be carefully. An example of this placement is given in figure 6.2.

Place the seed points with the left mouse button. While placing the seed points one can
scroll to other slices. Each out of plain seed point will be shown less brightly. Place at least
10 seed points or so and then run the filter on the CT image. Be sure to select that one
before running the filter.

The result should look like the ones in figure 6.3. To help understanding the 3D nature
of the data, select the newly created label layer and run the Isosurface Current Label
from the edit menu. This renders the isosurface of the current segmentation.

If parts of the skull are still missing, open up the Neighborhood Connected filter
again and add a few more seed points. Note that all the previous seed points are still there
to make it easier to add new points. To clear the seed points hit clear seed points in the
filter menu (if needed). To add additional regions just place seed points in those areas. Use
the isosurface rendering to check whether the skull is complete. Use the 3D view to see
where the slices are and then put seed points where needed.
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Figure 6.4. Filtering the brain dataset

6.3 Filtering MRI Data

The MR data contents a good data set for segmenting the gray and white matter. However
MR images tend to have a bit of noise on them. Often running the data through the median
filter will reduce the noise. Select the MR image in the Layer Menu and from the top menu
select the Median Filter from the Filters menu. Run this filter and compare it to the
previous MR image.

An easy way to do this is making all layers invisible, by clicking on the eye icons of
the individual layers, and then make the original and the filtered MR image visible. Now
select the top most image. Now the space bar will toggle between the two images. Navigate
through the windows and look at the differences.

A second very useful filter for MR data is the Intensity Correction Filter from the
filters menu. This filter takes a while to run but filters the intensity in the data that have
slight gradients due to the distance to the MR coils. The closer the image is to the location
of the MR coil, the brighter the images generally are. This filter uses a polynomial model
underneath to correct for this. We do this operation to make it easier to threshold the Gray
and White Matter.

Apply this filter and again look at the differences. The resulting image is also given in
figure 6.4.
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Figure 6.5. Load a pre-made rough segmentation of the brain

6.4 Masking out Brain

To mask out brain, the easiest is to manually generate a mask and paint with a brush a
rough segmentation of the brain cavity. The goal of masking out the data is to be able to
threshold the white and gray matter inside the skull without picking up data from the scalp.

To jump start the process a segmentation is available in the dataset. This one was
generated by manually painting the slices. Load the label layer through the Import Seg-
mentation menu from the FIle menu. Choose the Brain.nrrd dataset. After loading the
dataset, two new segmentations will be generated. One is the segmentation of the brain and
the other one is its inverse. As the segmentations are stored as labelmaps, where you can
have one label per pixel, the binary segmentation file will result in a mask for the value 0
and one for the value 1.

Delete the inverted mask by pressing the red cross on the layer. After loading the dataset
Seg3D should like the image depicted in figure 6.5.

Now use the Set Mask Label in the edit menu to set the Brain segmentation as a
mask. Now select the Intensity Corrected MR image and run the Mask Data from the
filters menu. Run this filter and it will create an image where all the scalp and skull are
masked out. (see figure 6.6). This masked out will now be used for segmenting the gray
and white matter.

CHAPTER 6. SEGMENTING A BRAIN DATASET 25



Figure 6.6. Mask brain data with hand painted segmentation

6.5 Thresholding Gray and White Matter

To segment the white matter, we select the Threshold Tool from the Tools menu. Before
using the tool make sure to clear the Masking layer, by selecting Clear Mask label from
the Edit menu.

Now select the Masked Data Volume. With the Threshold Tool insert a seed point in
the white matter. Keep adding seed points into the white matter. The threshold tool will
now segment all the points that are within the range of the seed points. Keep adding points
until the white matter has been marked. (see figure 6.7). Once the segmentation is good
enough press Complete in the menu on the left and a new masking layer will be created.

Repeat the same procedure for the gray matter (see figure 6.8). Finally one can use
the boolean operators to subtract the white matter from the gray matter. Copy the white
matter layer using Copy Label Filter, invert the new layer using Label Invert Filter
and then run Combine Labels with Logical And. The latter operation requires that one
of the layers is set as the masking layer. In this case do the and between the Gray matter
and the inverted White matter layer to mask out the white matter from the gray matter.

This concludes the tutorial. Feel free to explore other structures in the head and make
a full segmentation.
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Figure 6.7. Thresholding white matter using threshold range
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Figure 6.8. Thresholding grey matter using threshold range
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